You need Flash 8 to view the campaign
Download Flash 8